123

Pen Settings

CSS Base

Vendor Prefixing

Add External Stylesheets/Pens

Any URL's added here will be added as <link>s in order, and before the CSS in the editor. If you link to another Pen, it will include the CSS from that Pen. If the preprocessor matches, it will attempt to combine them before processing.

+ add another resource

You're using npm packages, so we've auto-selected Babel for you here, which we require to process imports and make it all work. If you need to use a different JavaScript preprocessor, remove the packages in the npm tab.

Add External Scripts/Pens

Any URL's added here will be added as <script>s in order, and run before the JavaScript in the editor. You can use the URL of any other Pen and it will include the JavaScript from that Pen.

+ add another resource

Use npm Packages

We can make npm packages available for you to use in your JavaScript. We use webpack to prepare them and make them available to import. We'll also process your JavaScript with Babel.

⚠️ This feature can only be used by logged in users.

Code Indentation

     

Save Automatically?

If active, Pens will autosave every 30 seconds after being saved once.

Auto-Updating Preview

If enabled, the preview panel updates automatically as you code. If disabled, use the "Run" button to update.

HTML Settings

Here you can Sed posuere consectetur est at lobortis. Donec ullamcorper nulla non metus auctor fringilla. Maecenas sed diam eget risus varius blandit sit amet non magna. Donec id elit non mi porta gravida at eget metus. Praesent commodo cursus magna, vel scelerisque nisl consectetur et.

            
              
<!--[if lt IE 9 ]>    <html class="lt-ie9"> <![endif]-->


<h1>how I'm fixing IE</h1>

<h2>an example</h2>
<pre>
<code>
.an-example {
  
  // put the IE9 and 'other' browser CSS declarations here  

  .lt-ie9 & { 
    
   // put the IE8 and below CSS declarations here
	 /* IE8 and below */ 
    
   // if you need IE7 as well then prefix the CSS with a *
	 /* IE7 and below */  
    
   // if you need IE6 as well then prefix the CSS with a _
	 /* IE6 */ 
      
    }
}
</code>
</pre>
            
          
!
            
              @import "compass/css3";

*{-webkit-box-sizing:border-box;-moz-box-sizing:border-box;box-sizing:border-box;}*{margin:0 auto;padding:0;}html{background-color:#383131;padding:0 3.124%;}img,video,object{height:auto;max-width:100%;}h1,h2,h3,h4,h5,h6{font-family:"Lucida Bright",Georgia,serif;color:#d15300;}blockquote,iframe,label,p,address,td,th,ul,ol,dl,dd,hr,table{font-family:"Lucida Grande","Lucida Sans Unicode","Lucida Sans",Geneva,Verdana,sans-serif;color:#F2F2F2;}pre,code{font-family:courier;}pre{background-color:rgba(255,255,255,0.8);padding:0 3.124%;padding-bottom:1.5rem;}code{padding-bottom:1.5rem;}h1,h2,h3,h4,h5,h6,blockquote,iframe,label,p,address,td,th,ul,ol,dl,dd,hr,table,pre,code{margin-bottom:1.5rem;line-height:1.5;}a{color:#d15300;text-decoration:none;}

// blank example 


.an-example {
  
  // put the IE9 and 'other' browser CSS declarations here  

  .lt-ie9 & { 
    
   // put the IE8 and below CSS declarations here
	 /* IE8 and below */ 
    
   // if you need IE7 as well then prefix the CSS with a *
	 /* IE7 and below */  
    
   // if you need IE6 as well then prefix the CSS with a _
	 /* IE6 */ 
      
    }
}

body {
	// put the IE9 and 'other' browser CSS declarations here
	
	  width: 100%;
    margin: 0 auto;
    
    .lt-ie9 & { 
    
    	// put the IE8 and below CSS declarations here
		  /* IE8 and below */ 
      
        width: 940px;
        margin: 0 auto;
        background: green;
    			
    	// if you need IE7 as well then prefix the CSS with a *
		 /* IE7 and below */  
        		
    // if you need IE6 as well then prefix the CSS with a /
		 /* IE6 */ 
			
    }
}




h1, h2 { color: white; }
            
          
!
            
              // use the IE conditional classes in the HTML example

// reference - https://github.com/h5bp/html5-boilerplate/blob/v4.0.2/doc/html.md#conditional-html-classes

// then use the example to hack around for IE6,7 and or 8 
            
          
!
999px
🕑 One or more of the npm packages you are using needs to be built. You're the first person to ever need it! We're building it right now and your preview will start updating again when it's ready.

Console