cssAudio - Activefile-genericCSS - ActiveGeneric - ActiveHTML - ActiveImage - ActiveJS - ActiveSVG - ActiveText - Activefile-genericVideo - ActiveLovehtmlicon-new-collectionicon-personicon-teamlog-outoctocatpop-outspinnerstartv

Pen Settings

CSS Base

Vendor Prefixing

Add External Stylesheets/Pens

Any URL's added here will be added as <link>s in order, and before the CSS in the editor. If you link to another Pen, it will include the CSS from that Pen. If the preprocessor matches, it will attempt to combine them before processing.

Quick-add: + add another resource

Add External Scripts/Pens

Any URL's added here will be added as <script>s in order, and run before the JavaScript in the editor. You can use the URL of any other Pen and it will include the JavaScript from that Pen.

Quick-add: + add another resource

Code Indentation

     

Save Automatically?

If active, Pens will autosave every 30 seconds after being saved once.

Auto-Updating Preview

If enabled, the preview panel updates automatically as you code. If disabled, use the "Run" button to update.

            
              <h1>YouTube Play Button with No Text</h1>

<p>
  This is technically not a Rick Roll since I am showing something here.
</p>

<p>
  Anyway, if you view the source of the rendered embedded video below, you will see the play <code>&lt;button&gt;</code> has no accessible name. You can experience this with a screen reader, which is easier than diving into the code.
</p>

<h2>Embedded video:</h2>

<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ?rel=0" frameborder="0" allowfullscreen></iframe>

<h2>Embed code:</h2>

<pre style="overflow:auto;">&lt;iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ?rel=0" frameborder="0" allowfullscreen&gt;&lt;/iframe&gt;</pre>

<h3>The play button code:</h3>

<pre style="overflow:auto;">
&lt;div class="ytp-cued-thumbnail-overlay" data-layer="4" style=""&gt;
  &lt;div class="ytp-cued-thumbnail-overlay-image" style="background-image: url(&quot;https://i.ytimg.com/vi/dQw4w9WgXcQ/maxresdefault.jpg&quot;);"&gt;&lt;/div&gt;
  &lt;button class="ytp-large-play-button ytp-button"&gt;
    &lt;svg height="100%" version="1.1" viewBox="0 0 68 48" width="100%"&gt;
      &lt;path class="ytp-large-play-button-bg" d="m .66,37.62 c 0,0 .66,4.70 2.70,6.77 2.58,2.71 5.98,2.63 7.49,2.91 5.43,.52 23.10,.68 23.12,.68 .00,-1.3e-5 14.29,-0.02 23.81,-0.71 1.32,-0.15 4.22,-0.17 6.81,-2.89 2.03,-2.07 2.70,-6.77 2.70,-6.77 0,0 .67,-5.52 .67,-11.04 l 0,-5.17 c 0,-5.52 -0.67,-11.04 -0.67,-11.04 0,0 -0.66,-4.70 -2.70,-6.77 C 62.03,.86 59.13,.84 57.80,.69 48.28,0 34.00,0 34.00,0 33.97,0 19.69,0 10.18,.69 8.85,.84 5.95,.86 3.36,3.58 1.32,5.65 .66,10.35 .66,10.35 c 0,0 -0.55,4.50 -0.66,9.45 l 0,8.36 c .10,4.94 .66,9.45 .66,9.45 z" fill="#1f1f1e" fill-opacity="0.81"&gt;&lt;/path&gt;
      &lt;path d="m 26.96,13.67 18.37,9.62 -18.37,9.55 -0.00,-19.17 z" fill="#fff"&gt;&lt;/path&gt;
      &lt;path d="M 45.02,23.46 45.32,23.28 26.96,13.67 43.32,24.34 45.02,23.46 z" fill="#ccc"&gt;&lt;/path&gt;
    &lt;/svg&gt;
  &lt;/button&gt;
&lt;/div&gt;
</pre>

<p>
  If you dig around and look for an <code>aria-label</code> you may find this block, but it only appears <em>after</em> the video has started playing:
</p>

<pre style="overflow:auto;">
&lt;button class="ytp-play-button ytp-button" <mark>aria-label="Play"</mark>&gt;
  &lt;svg height="100%" version="1.1" viewBox="0 0 36 36" width="100%"&gt;
    &lt;use class="ytp-svg-shadow" xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="#ytp-id-11"&gt;&lt;/use&gt;
    &lt;path class="ytp-svg-fill" d="M 12,26 18.5,22 18.5,14 12,10 z M 18.5,22 25,18 25,18 18.5,14 z" id="ytp-id-11"&gt;&lt;/path&gt;
  &lt;/svg&gt;
&lt;/button&gt;
</pre>

<h2>Looking for feedback:</h2>

<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Tested in Chrome 60 / Win10, MacOS Safari &amp; Firefox (thanks to <a href="https://twitter.com/FriendlyAshley">@FriendlyAshley</a> <a href="https://twitter.com/sloandr">@sloandr</a>). Looking for feedback before I submit bug report.</p>&mdash; Adrian Roselli (@aardrian) <a href="https://twitter.com/aardrian/status/895338597930422272">August 9, 2017</a></blockquote>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>


<h3>Bug reported (sorta):</h3>

<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr"><a href="https://twitter.com/googleaccess">@googleaccess</a> I see no dedicated YouTube a11y account. I just filed this using “Send feedback” link on a YT page. <a href="https://t.co/OIgaePKXaa">https://t.co/OIgaePKXaa</a></p>&mdash; Adrian Roselli (@aardrian) <a href="https://twitter.com/aardrian/status/895342687490121728">August 9, 2017</a></blockquote>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

            
          
!
999px
Loading ..................

Console